summaryrefslogtreecommitdiff
path: root/Tests/Tutorial/Step3/CMakeLists.txt
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2013-02-13 18:21:12 -0800
committerAnas Nashif <anas.nashif@intel.com>2013-02-13 18:21:12 -0800
commitef8aa19c33e83ff019595fd7f8fdc29c35c336a3 (patch)
tree6501b44707b5c6a88fa5f817adee1a3ffcb0012d /Tests/Tutorial/Step3/CMakeLists.txt
parent035c7fabc3b82cbc9a346c11abe2e9462b4c0379 (diff)
downloadcmake-b76f3d62b9ae70b9fe053f294d35613bb3127797.tar.gz
cmake-b76f3d62b9ae70b9fe053f294d35613bb3127797.tar.bz2
cmake-b76f3d62b9ae70b9fe053f294d35613bb3127797.zip
Imported Upstream version 2.8.10.2upstream/2.8.10.2
Diffstat (limited to 'Tests/Tutorial/Step3/CMakeLists.txt')
-rw-r--r--Tests/Tutorial/Step3/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/Tests/Tutorial/Step3/CMakeLists.txt b/Tests/Tutorial/Step3/CMakeLists.txt
index 0b05fd737..762302bc5 100644
--- a/Tests/Tutorial/Step3/CMakeLists.txt
+++ b/Tests/Tutorial/Step3/CMakeLists.txt
@@ -24,7 +24,7 @@ if (USE_MYMATH)
include_directories ("${PROJECT_SOURCE_DIR}/MathFunctions")
add_subdirectory (MathFunctions)
set (EXTRA_LIBS ${EXTRA_LIBS} MathFunctions)
-endif (USE_MYMATH)
+endif ()
# add the executable
add_executable (Tutorial tutorial.cxx)
@@ -32,7 +32,7 @@ target_link_libraries (Tutorial ${EXTRA_LIBS})
# add the install targets
install (TARGETS Tutorial DESTINATION bin)
-install (FILES "${PROJECT_BINARY_DIR}/TutorialConfig.h"
+install (FILES "${PROJECT_BINARY_DIR}/TutorialConfig.h"
DESTINATION include)
@@ -44,7 +44,7 @@ add_test (TutorialRuns Tutorial 25)
# does it sqrt of 25
add_test (TutorialComp25 Tutorial 25)
-set_tests_properties (TutorialComp25
+set_tests_properties (TutorialComp25
PROPERTIES PASS_REGULAR_EXPRESSION "25 is 5"
)
@@ -63,6 +63,6 @@ set_tests_properties (TutorialSmall
# does the usage message work?
add_test (TutorialUsage Tutorial)
set_tests_properties (TutorialUsage
- PROPERTIES
+ PROPERTIES
PASS_REGULAR_EXPRESSION "Usage:.*number"
)