summaryrefslogtreecommitdiff
path: root/Tests/Cuda/MixedStandardLevels/CMakeLists.txt
diff options
context:
space:
mode:
authorSlava Barinov <v.barinov@samsung.com>2020-01-28 13:05:03 +0300
committerSlava Barinov <v.barinov@samsung.com>2020-01-28 13:05:03 +0300
commit2ed89a511a84c595eb24af625bc0bd88f5a3ce21 (patch)
tree2b382dc518dc3fa4a496529cb87bf6f8d8a0f6ec /Tests/Cuda/MixedStandardLevels/CMakeLists.txt
parent5a33b45a98929bb730e6a11818416edd27e8fc00 (diff)
downloadcmake-sandbox/vbarinov/dotnet_upgrade.tar.gz
cmake-sandbox/vbarinov/dotnet_upgrade.tar.bz2
cmake-sandbox/vbarinov/dotnet_upgrade.zip
Signed-off-by: Slava Barinov <v.barinov@samsung.com>
Diffstat (limited to 'Tests/Cuda/MixedStandardLevels/CMakeLists.txt')
-rw-r--r--Tests/Cuda/MixedStandardLevels/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/Tests/Cuda/MixedStandardLevels/CMakeLists.txt b/Tests/Cuda/MixedStandardLevels/CMakeLists.txt
new file mode 100644
index 000000000..b399662a7
--- /dev/null
+++ b/Tests/Cuda/MixedStandardLevels/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.7)
+project(MixedStandardLevels CXX CUDA)
+
+string(APPEND CMAKE_CUDA_FLAGS " -gencode arch=compute_30,code=compute_30")
+
+set(CMAKE_CXX_STANDARD 11)
+
+add_executable(MixedStandardLevels main.cu)
+target_compile_features(MixedStandardLevels PUBLIC cxx_std_11)
+
+if(APPLE)
+ # Help the static cuda runtime find the driver (libcuda.dyllib) at runtime.
+ set_property(TARGET MixedStandardLevels PROPERTY BUILD_RPATH ${CMAKE_CUDA_IMPLICIT_LINK_DIRECTORIES})
+endif()