summaryrefslogtreecommitdiff
path: root/Tests/CSharpLinkToCxx/CMakeLists.txt
diff options
context:
space:
mode:
authorDongHun Kwak <dh0128.kwak@samsung.com>2021-10-08 09:13:29 +0900
committerDongHun Kwak <dh0128.kwak@samsung.com>2021-10-08 09:13:29 +0900
commit0093b6749408dc1fa6c0578865555750171940a9 (patch)
tree150446d9eff60021385a36d07f0a92c9d3c47851 /Tests/CSharpLinkToCxx/CMakeLists.txt
parentd3ab5eb53d4ef4c187524c2804aa6e0a6406da89 (diff)
downloadcmake-0093b6749408dc1fa6c0578865555750171940a9.tar.gz
cmake-0093b6749408dc1fa6c0578865555750171940a9.tar.bz2
cmake-0093b6749408dc1fa6c0578865555750171940a9.zip
Imported Upstream version 3.12.3upstream/3.12.3
Diffstat (limited to 'Tests/CSharpLinkToCxx/CMakeLists.txt')
-rw-r--r--Tests/CSharpLinkToCxx/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/CSharpLinkToCxx/CMakeLists.txt b/Tests/CSharpLinkToCxx/CMakeLists.txt
index 153c57c90..a3067afa2 100644
--- a/Tests/CSharpLinkToCxx/CMakeLists.txt
+++ b/Tests/CSharpLinkToCxx/CMakeLists.txt
@@ -21,3 +21,9 @@ target_link_libraries(CSharpLinkToCxx CLIApp)
# because it is unmanaged
add_library(CppNativeApp SHARED cpp_native.hpp cpp_native.cpp)
target_link_libraries(CSharpLinkToCxx CppNativeApp)
+
+# Link a static C++ library into the CSharp executable.
+# We do not actually use any symbols but this helps cover
+# link language selection.
+add_library(CppStaticLib STATIC cpp_static.cpp)
+target_link_libraries(CSharpLinkToCxx CppStaticLib)