summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..065535c
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,38 @@
+SUBDIRS = testsuite deb
+
+docdir = $(prefix)/doc/$(PACKAGE)-$(VERSION)
+
+doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README
+
+bin_PROGRAMS = chrpath
+
+man_MANS = chrpath.1
+
+debs:
+ fakeroot debian/rules binary
+
+chrpath_SOURCES = \
+ chrpath.c \
+ killrpath.c \
+ main.c \
+ elf.c \
+ protos.h
+
+EXTRA_DIST = ChangeLog.usermap $(man_MANS)
+
+CLEANFILES = *.bb *.bbg *.da *.gcov testsuite/*.bb testsuite/*.bbg
+coverage: all check
+ for f in *.c; do gcov $$f; done
+
+# ChangeLog autogenerated from CVS log messages
+#
+# -b Show brach information
+# --gmt Use GTM timezone, not local time
+# --window 7200 Use a two hour window when grouping log messages
+# --log-opts -d'...<now' Log everything from the given date
+# --usermap ... Make usernames with names/emails in given file
+# --ignore ChangeLog Don't log changes to the ChangeLog itself
+CVS2CL = cvs2cl
+log: ChangeLog.usermap
+ $(CVS2CL) -b --gmt --log-opts "-d'2001-01-01< now'" --window 7200 \
+ --usermap ChangeLog.usermap --ignore ChangeLog -f ChangeLog