summaryrefslogtreecommitdiff
path: root/src/caffe/proto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/caffe/proto/CMakeLists.txt')
-rw-r--r--src/caffe/proto/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/caffe/proto/CMakeLists.txt b/src/caffe/proto/CMakeLists.txt
index a4b2c00e..186a8565 100644
--- a/src/caffe/proto/CMakeLists.txt
+++ b/src/caffe/proto/CMakeLists.txt
@@ -1,4 +1,3 @@
-cmake_minimum_required(VERSION 2.8)
project( Proto )
# Google Protocol Buffers
@@ -23,6 +22,9 @@ add_library(proto
target_link_libraries(proto ${PROTOBUF_LIBRARIES})
+# Create proto include directory
+file(MAKE_DIRECTORY ${CMAKE_SOURCE_DIR}/include/caffe/proto)
+
# Copy proto headers to include/caffe/proto/
foreach(header ${ProtoHeaders})