summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorphilkr <philkr@users.noreply.github.com>2015-02-17 10:50:12 -0800
committerphilkr <philkr@users.noreply.github.com>2015-02-24 14:06:36 -0800
commit54037d3942647ff3659028e1d7437f2e8f7cf911 (patch)
tree0fc3d12c933c3970f9e47f1c1f29d01492fc1f9d /CMakeLists.txt
parent682d9da0dba98788dd01723a16a257df4382376c (diff)
downloadcaffeonacl-54037d3942647ff3659028e1d7437f2e8f7cf911.tar.gz
caffeonacl-54037d3942647ff3659028e1d7437f2e8f7cf911.tar.bz2
caffeonacl-54037d3942647ff3659028e1d7437f2e8f7cf911.zip
Making python3 work with cmake and the new python wrapper
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index adea37be..626d5b44 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,7 @@ caffe_option(CPU_ONLY "Build Caffe wihtout CUDA support" OFF) # TODO: rename to
caffe_option(USE_CUDNN "Build Caffe with cuDNN libary support" ON IF NOT CPU_ONLY)
caffe_option(BUILD_SHARED_LIBS "Build shared libraries" ON)
caffe_option(BUILD_python "Build Python wrapper" ON)
+set(python_version "2" CACHE STRING "Specify which python version to use")
caffe_option(BUILD_matlab "Build Matlab wrapper" OFF IF UNIX OR APPLE)
caffe_option(BUILD_docs "Build documentation" ON IF UNIX OR APPLE)