summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorray glover <ray.glover@uk.ibm.com>2016-05-10 15:44:47 +0100
committerray glover <ray.glover@uk.ibm.com>2016-05-10 15:47:07 +0100
commita934ca54f3633479ea0573346c510df4f757df6c (patch)
tree49392cadeeaca9f47308393c4efd6e0fd41c3a08 /CMakeLists.txt
parentd24256495970b8a5031365ed6763739677ac4543 (diff)
downloadcaffe-a934ca54f3633479ea0573346c510df4f757df6c.tar.gz
caffe-a934ca54f3633479ea0573346c510df4f757df6c.tar.bz2
caffe-a934ca54f3633479ea0573346c510df4f757df6c.zip
[build] (CMake) customisable Caffe version/soversion
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c5d99cef..da7142c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,8 +10,8 @@ endif()
project(Caffe C CXX)
# ---[ Caffe version
-set(CAFFE_TARGET_VERSION "1.0.0-rc3")
-set(CAFFE_TARGET_SOVERSION "1.0.0-rc3")
+set(CAFFE_TARGET_VERSION "1.0.0-rc3" CACHE STRING "Caffe logical version")
+set(CAFFE_TARGET_SOVERSION "1.0.0-rc3" CACHE STRING "Caffe soname version")
add_definitions(-DCAFFE_VERSION=${CAFFE_TARGET_VERSION})
# ---[ Using cmake scripts and modules