summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 12b6151..797940a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,6 +5,22 @@ AM_CONFIG_HEADER([config.h])
AM_MAINTAINER_MODE
AM_INIT_AUTOMAKE
+dnl sed is mandatory for configure process
+AC_PATH_PROG([SED], [sed], [not found],
+ [$PATH:/usr/bin:/usr/local/bin])
+AC_SUBST([SED])
+if test -z "$SED" || test "$SED" = "not found"; then
+ AC_MSG_ERROR([Cannot continue without sed.])
+fi
+
+dnl grep is mandatory for configure process
+AC_PATH_PROG([GREP], [grep], [not found],
+ [$PATH:/usr/bin:/usr/local/bin])
+AC_SUBST([GREP])
+if test -z "$GREP" || test "$GREP" = "not found"; then
+ AC_MSG_ERROR([Cannot continue without grep.])
+fi
+
dnl
dnl Detect the canonical host and target build environment
dnl