summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-09-18 13:56:56 +0000
committerYang Tse <yangsita@gmail.com>2008-09-18 13:56:56 +0000
commit5e9d41fb2917a0fc0f81057f0ffa0c1508c1a22a (patch)
tree60edd105c9760208fdfa0b617137661e55c20ece /configure.ac
parentfeb2043b43619ec36ecaa9f6f830c8c79b6a0a80 (diff)
downloadc-ares-5e9d41fb2917a0fc0f81057f0ffa0c1508c1a22a.tar.gz
c-ares-5e9d41fb2917a0fc0f81057f0ffa0c1508c1a22a.tar.bz2
c-ares-5e9d41fb2917a0fc0f81057f0ffa0c1508c1a22a.zip
icc adjustments
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f0e1a04..666facd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -229,6 +229,12 @@ if test "$curl_cv_have_def___INTEL_COMPILER" = "yes"; then
dnl On Linux this compiler uses gcc's header files, so
dnl we select ANSI C89 dialect plus GNU extensions.
CPPFLAGS="$CPPFLAGS -std=gnu89"
+ if test "$curl_cv_def___INTEL_COMPILER" -gt "600"; then
+ dnl Show errors, warnings, and remarks
+ CPPFLAGS="$CPPFLAGS -Wall"
+ dnl Perform extra compile-time code checking
+ CPPFLAGS="$CPPFLAGS -Wcheck"
+ fi
dnl Change some warnings into errors
dnl #140: too many arguments in function call
dnl #147: declaration is incompatible with 'previous one'