summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2006-05-10 08:03:54 +0000
committerDaniel Stenberg <daniel@haxx.se>2006-05-10 08:03:54 +0000
commite75c876ac50b7e38e7ca0897e79a9f5f02d319cd (patch)
tree99fcedc2a841dc72db2ed0536b7b0636fd353559 /configure.ac
parentc8878fb5848e1f2e2355ca4bd04defd7094f756d (diff)
downloadc-ares-e75c876ac50b7e38e7ca0897e79a9f5f02d319cd.tar.gz
c-ares-e75c876ac50b7e38e7ca0897e79a9f5f02d319cd.tar.bz2
c-ares-e75c876ac50b7e38e7ca0897e79a9f5f02d319cd.zip
Bram Matthys brought my attention to a libtool peculiarity where detecting
things such as C++ compiler actually is a bad thing and since we don't need that detection I added a work-around, much inspired by a previous patch by Paolo Bonzini. This also shortens the configure script quite a lot.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ea38b89..f862f8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,7 @@ AC_HELP_STRING([--disable-debug],[Disable debug options]),
)
dnl libtool setup
+CARES_CLEAR_LIBTOOL_TAGS
AC_PROG_LIBTOOL
dnl Checks for header files.
@@ -433,7 +434,8 @@ int main()
}
], [
AC_MSG_RESULT(yes)
- AC_DEFINE_UNQUOTED(HAVE_INET_NTOP_IPV6,1,[Define to 1 if inet_ntop supports IPv6.])
+ AC_DEFINE_UNQUOTED(HAVE_INET_NTOP_IPV6,1,
+ [Define to 1 if inet_ntop supports IPv6.])
], AC_MSG_RESULT(no),AC_MSG_RESULT(no))
fi
@@ -499,13 +501,15 @@ dnl and get the types of five of its arguments.
CURL_CHECK_FUNC_GETNAMEINFO
-dnl God bless non-standardized functions! We need to see which getservbyport_r variant is available
+dnl God bless non-standardized functions! We need to see which getservbyport_r
+dnl variant is available
CARES_CHECK_GETSERVBYPORT_R
CURL_CHECK_NONBLOCKING_SOCKET
AC_C_BIGENDIAN(
- [AC_DEFINE(ARES_BIG_ENDIAN, 1, [define this if ares is built for a big endian system])],
+ [AC_DEFINE(ARES_BIG_ENDIAN, 1,
+ [define this if ares is built for a big endian system])],
,
[AC_MSG_WARN([couldn't figure out endianess, assuming little endian!])]
)