summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2004-02-18 12:26:27 +0000
committerDaniel Stenberg <daniel@haxx.se>2004-02-18 12:26:27 +0000
commitdd6dd055b3f0e4c0a650d12ec7c868c5a03da3ce (patch)
treeaf4083a59f59f9d8f39b3a0eabccac0778bd2c87 /configure.ac
parent9264a4649d22fd14f32e38e322b88eeb84fa5c99 (diff)
downloadc-ares-dd6dd055b3f0e4c0a650d12ec7c868c5a03da3ce.tar.gz
c-ares-dd6dd055b3f0e4c0a650d12ec7c868c5a03da3ce.tar.bz2
c-ares-dd6dd055b3f0e4c0a650d12ec7c868c5a03da3ce.zip
I removed the socklen_t requirement from memdebug.h, so we don't need to
figure it out here anymore to build debug builds.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 0 insertions, 48 deletions
diff --git a/configure.ac b/configure.ac
index 334bb1e..abb65d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,51 +15,6 @@ esac
AC_SEARCH_LIBS(gethostbyname, nsl)
AC_SEARCH_LIBS(socket, socket)
-dnl Check for socklen_t: historically on BSD it is an int, and in
-dnl POSIX 1g it is a type of its own, but some platforms use different
-dnl types for the argument to getsockopt, getpeername, etc. So we
-dnl have to test to find something that will work.
-AC_DEFUN([TYPE_SOCKLEN_T],
-[
- AC_CHECK_TYPE([socklen_t], ,[
- AC_MSG_CHECKING([for socklen_t equivalent])
- AC_CACHE_VAL([curl_cv_socklen_t_equiv],
- [
- # Systems have either "struct sockaddr *" or
- # "void *" as the second argument to getpeername
- curl_cv_socklen_t_equiv=
- for arg2 in "struct sockaddr" void; do
- for t in int size_t unsigned long "unsigned long"; do
- AC_TRY_COMPILE([
- #ifdef HAVE_SYS_TYPES_H
- #include <sys/types.h>
- #endif
- #ifdef HAVE_SYS_SOCKET_H
- #include <sys/socket.h>
- #endif
-
- int getpeername (int, $arg2 *, $t *);
- ],[
- $t len;
- getpeername(0,0,&len);
- ],[
- curl_cv_socklen_t_equiv="$t"
- break
- ])
- done
- done
-
- if test "x$curl_cv_socklen_t_equiv" = x; then
- AC_MSG_ERROR([Cannot find a type to use in place of socklen_t])
- fi
- ])
- AC_MSG_RESULT($curl_cv_socklen_t_equiv)
- AC_DEFINE_UNQUOTED(socklen_t, $curl_cv_socklen_t_equiv,
- [type to use in place of socklen_t if not defined])],
- [#include <sys/types.h>
-#include <sys/socket.h>])
-])
-
dnl ************************************************************
dnl Option to switch on debug options. This makes an assumption that
dnl this is built as an 'ares' subdir in the curl source tree. Subject for
@@ -75,9 +30,6 @@ AC_HELP_STRING([--disable-debug],[Disable debug options]),
;;
*) AC_MSG_RESULT(yes)
- dnl we need the socklen_t type when we built with the curl memdebug stuff
- TYPE_SOCKLEN_T
-
CPPFLAGS="$CPPFLAGS -DCURLDEBUG -I../include"
CFLAGS="$CFLAGS -g"
if test "$GCC" = "yes"; then