summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2005-06-02 11:58:04 +0000
committerDaniel Stenberg <daniel@haxx.se>2005-06-02 11:58:04 +0000
commit4e9c5b2dbb6b30b2662a70d9756d717d63475df8 (patch)
tree1557100c90922cff0a4ab212a4c13d97bbef357e /configure.ac
parentae75ee14234b6d1b22832081d7dbd1d281c955cb (diff)
downloadc-ares-4e9c5b2dbb6b30b2662a70d9756d717d63475df8.tar.gz
c-ares-4e9c5b2dbb6b30b2662a70d9756d717d63475df8.tar.bz2
c-ares-4e9c5b2dbb6b30b2662a70d9756d717d63475df8.zip
William Ahern:
Make UDP sockets non-blocking. I've confirmed that at least on Linux 2.4 a read event can come back from poll() on a valid SOCK_DGRAM socket but recv(2) will still block. This patch doesn't ignore EAGAIN in read_udp_packets(), though maybe it should. (This patch was edited by Daniel Stenberg and a new configure test was added (imported from curl's configure) to properly detect what non-blocking socket approach to use.)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1201198..e3a9c96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -328,5 +328,6 @@ AC_CHECK_SIZEOF(struct in_addr, ,
AC_CHECK_FUNCS([bitncmp if_indextoname])
+CURL_CHECK_NONBLOCKING_SOCKET
AC_OUTPUT(Makefile)