summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2004-02-04 07:47:04 +0000
committerDaniel Stenberg <daniel@haxx.se>2004-02-04 07:47:04 +0000
commit2bf1e41f4664923ddb045b52e26efcd385a889ee (patch)
treed9e061cf282a6da07ecd569d845a9cadd963abd7 /configure.ac
parentbc2130369565fee41b326a7544332e65241af3eb (diff)
downloadc-ares-2bf1e41f4664923ddb045b52e26efcd385a889ee.tar.gz
c-ares-2bf1e41f4664923ddb045b52e26efcd385a889ee.tar.bz2
c-ares-2bf1e41f4664923ddb045b52e26efcd385a889ee.zip
use configure.ac instead of configure.in
support --enable-debug to switch on picky compiler options
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..45c0109
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,57 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(ares_init.c)
+
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+AC_CANONICAL_HOST
+case $host_os in
+solaris*)
+ AC_DEFINE(ETC_INET)
+ ;;
+esac
+
+AC_SEARCH_LIBS(gethostbyname, nsl)
+AC_SEARCH_LIBS(socket, socket)
+
+dnl ************************************************************
+dnl lame option to switch on debug options
+dnl
+AC_MSG_CHECKING([whether to enable debug options])
+AC_ARG_ENABLE(debug,
+AC_HELP_STRING([--enable-debug],[Enable pedantic debug options])
+AC_HELP_STRING([--disable-debug],[Disable debug options]),
+[ case "$enableval" in
+ no)
+ AC_MSG_RESULT(no)
+ ;;
+ *) AC_MSG_RESULT(yes)
+
+ CPPFLAGS="$CPPFLAGS -DCURLDEBUG"
+ CFLAGS="$CFLAGS -g"
+ if test "$GCC" = "yes"; then
+ CFLAGS="$CFLAGS -W -Wall -Wwrite-strings -pedantic -Wno-long-long -Wundef -Wpointer-arith -Wnested-externs"
+
+ dnl here's a more aggressive set to use:
+ dnl CFLAGS="$CFLAGS -W -Wall -Wwrite-strings -pedantic -Wno-long-long -Wundef -Wpointer-arith -Wnested-externs -Wcast-align -Winline -Wstrict-prototypes -Wmissing-declarations -Wmissing-prototypes -Wshadow -Wfloat-equal -Wsign-compare -Wunreachable-code"
+ fi
+ dnl strip off optimizer flags
+ NEWFLAGS=""
+ for flag in $CFLAGS; do
+ case "$flag" in
+ -O*)
+ dnl echo "cut off $flag"
+ ;;
+ *)
+ NEWFLAGS="$NEWFLAGS $flag"
+ ;;
+ esac
+ done
+ CFLAGS=$NEWFLAGS
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+
+AC_OUTPUT(Makefile)