summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2009-06-20 17:24:43 +0000
committerYang Tse <yangsita@gmail.com>2009-06-20 17:24:43 +0000
commitcdcc3aca8ce7811103a51f36fc832a12da0212ae (patch)
tree9d0a34514f57222b66a853811b5062f2ff74c663 /configure.ac
parentdab4d1afbc01c576d5026c502e91c00f8ec7c480 (diff)
downloadc-ares-cdcc3aca8ce7811103a51f36fc832a12da0212ae.tar.gz
c-ares-cdcc3aca8ce7811103a51f36fc832a12da0212ae.tar.bz2
c-ares-cdcc3aca8ce7811103a51f36fc832a12da0212ae.zip
Refactor how libraries are checked for connect() function,
and check for connect() as it is done for other functions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index eda89eb..6f32b95 100644
--- a/configure.ac
+++ b/configure.ac
@@ -337,8 +337,7 @@ if test "$ac_cv_lib_resolve_strcasecmp" = "$ac_cv_func_strcasecmp"; then
fi
ac_cv_func_strcasecmp="no"
-dnl socket lib?
-AC_CHECK_FUNC(connect, , [ AC_CHECK_LIB(socket, connect) ])
+CARES_CHECK_LIBS_CONNECT
dnl **********************************************************************
dnl In case that function clock_gettime with monotonic timer is available,
@@ -537,6 +536,7 @@ CURL_CHECK_MSG_NOSIGNAL
CARES_CHECK_FUNC_CLOSESOCKET
CARES_CHECK_FUNC_CLOSESOCKET_CAMEL
+CARES_CHECK_FUNC_CONNECT
CARES_CHECK_FUNC_FCNTL
CARES_CHECK_FUNC_FREEADDRINFO
CARES_CHECK_FUNC_GETADDRINFO