summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2009-05-28 14:38:04 +0000
committerYang Tse <yangsita@gmail.com>2009-05-28 14:38:04 +0000
commit96f34988f4130a71bb7975664363d94b243204e8 (patch)
tree361e0529f5b30ac0d6786a35a2d9e87d31588432 /configure.ac
parent7a5621876b33f7e851a2b249f23c29849481bf9b (diff)
downloadc-ares-96f34988f4130a71bb7975664363d94b243204e8.tar.gz
c-ares-96f34988f4130a71bb7975664363d94b243204e8.tar.bz2
c-ares-96f34988f4130a71bb7975664363d94b243204e8.zip
c-ares' --enable-curldebug adjustments
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 6 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index e8dff99..3c8c0ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,22 +110,6 @@ esac
dnl libtool setup
AC_PROG_LIBTOOL
-CARES_CHECK_CURLDEBUG
-
-AM_CONDITIONAL(CURLDEBUG, test x$want_curldebug = xyes)
-
-AC_MSG_CHECKING([if we need -no-undefined])
-case $host in
- *-*-cygwin* | *-*-mingw* | *-*-pw32* | *-*-cegcc*)
- need_no_undefined=yes
- ;;
- *)
- need_no_undefined=no
- ;;
-esac
-AC_MSG_RESULT($need_no_undefined)
-AM_CONDITIONAL(NO_UNDEFINED, test x$need_no_undefined = xyes)
-
dnl **********************************************************************
dnl platform/compiler/architecture specific checks/flags
dnl **********************************************************************
@@ -161,6 +145,12 @@ esac
CARES_CHECK_COMPILER_HALT_ON_ERROR
CARES_CHECK_COMPILER_ARRAY_SIZE_NEGATIVE
+CARES_CHECK_NO_UNDEFINED
+AM_CONDITIONAL(NO_UNDEFINED, test x$need_no_undefined = xyes)
+
+CARES_CHECK_CURLDEBUG
+AM_CONDITIONAL(CURLDEBUG, test x$want_curldebug = xyes)
+
dnl **********************************************************************
dnl Compilation based checks should not be done before this point.
dnl **********************************************************************