summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2010-11-13 04:15:16 +0100
committerYang Tse <yangsita@gmail.com>2010-11-13 04:15:16 +0100
commit0b504d7065902b22496b559029fe51dbcddba97f (patch)
tree47199ae9f927fb7d7be64fa9ab9d715a7d0f6dd0 /configure.ac
parentdac69d52c254feb97c3ae066737fc016e80aa4c4 (diff)
downloadc-ares-0b504d7065902b22496b559029fe51dbcddba97f.tar.gz
c-ares-0b504d7065902b22496b559029fe51dbcddba97f.tar.bz2
c-ares-0b504d7065902b22496b559029fe51dbcddba97f.zip
configure: fix autoconf 2.68 warning: no AC_LANG_SOURCE call detected in body
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 11 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index d505e16..0f47d9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -476,11 +476,17 @@ AC_CHECK_TYPE(long long,
if test "xyes" = "x$longlong"; then
AC_MSG_CHECKING([if numberLL works])
- AC_COMPILE_IFELSE([long long val = 1000LL;],
- [AC_DEFINE(HAVE_LL, 1, [if your compiler supports LL])]
- AC_MSG_RESULT(yes),
- AC_MSG_RESULT(no)
- )
+ AC_COMPILE_IFELSE([
+ AC_LANG_PROGRAM([[
+ ]],[[
+ long long val = 1000LL;
+ ]])
+ ],[
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_LL, 1, [if your compiler supports LL])
+ ],[
+ AC_MSG_RESULT([no])
+ ])
fi