summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2005-09-21 09:01:44 +0000
committerDaniel Stenberg <daniel@haxx.se>2005-09-21 09:01:44 +0000
commitcbe5ec459708e78eed6c3b8db236e43a35342c29 (patch)
tree720e4d31dc50c9f9af0eaae0b461dde1e9af7217 /configure.ac
parent6afd5c16d3f7377d47ee3d9bb3237b636cfe2f35 (diff)
downloadc-ares-cbe5ec459708e78eed6c3b8db236e43a35342c29.tar.gz
c-ares-cbe5ec459708e78eed6c3b8db236e43a35342c29.tar.bz2
c-ares-cbe5ec459708e78eed6c3b8db236e43a35342c29.zip
fixed the check for the addrinfo struct
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a04205c..16db0f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,7 @@ AC_CHECK_HEADERS(
sys/select.h \
sys/socket.h \
sys/ioctl.h \
+ netdb.h \
winsock.h \
netinet/in.h \
net/if.h \
@@ -195,7 +196,9 @@ AC_CHECK_MEMBER(struct sockaddr_in6.sin6_scope_id,
fi
dnl check for the addrinfo structure
-CARES_CHECK_STRUCT(
+AC_CHECK_MEMBER(struct addrinfo.ai_flags,
+ AC_DEFINE_UNQUOTED(HAVE_STRUCT_ADDRINFO,1,
+ [Define to 1 if you have struct addrinfo.]),,
[
#ifdef HAVE_SYS_TYPES_H
#include <sys/types.h>
@@ -206,9 +209,13 @@ CARES_CHECK_STRUCT(
#ifdef HAVE_NETINET_IN_H
#include <netinet/in.h>
#endif
- ], [addrinfo],
- AC_DEFINE_UNQUOTED(HAVE_STRUCT_ADDRINFO,1,
- [Define to 1 if you have struct addrinfo.])
+#ifdef HAVE_SYS_SOCKET_H
+#include <sys/socket.h>
+#endif
+#ifdef HAVE_NETDB_H
+#include <netdb.h>
+#endif
+ ]
)
dnl check for inet_pton