summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2005-11-15 14:39:52 +0000
committerDaniel Stenberg <daniel@haxx.se>2005-11-15 14:39:52 +0000
commit264f2a4cf185968ecae2bc1ba70bf9c5edfe19c0 (patch)
treeb5085d7d8a0087428acf14435fe821286246f8c4 /configure.ac
parent374bc69debc074fc67c187d24b52a394dc5f4656 (diff)
downloadc-ares-264f2a4cf185968ecae2bc1ba70bf9c5edfe19c0.tar.gz
c-ares-264f2a4cf185968ecae2bc1ba70bf9c5edfe19c0.tar.bz2
c-ares-264f2a4cf185968ecae2bc1ba70bf9c5edfe19c0.zip
include ws2tcpip.h in an attempt to detect some of the ipv6 structs better
in mingw builds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c20685b..24dc7ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,6 +68,7 @@ AC_CHECK_HEADERS(
sys/ioctl.h \
netdb.h \
winsock.h \
+ ws2tcpip.h \
netinet/in.h \
net/if.h \
arpa/nameser.h \
@@ -152,6 +153,9 @@ CARES_CHECK_STRUCT(
#ifdef HAVE_WINSOCK_H
#include <winsock.h>
#endif
+#ifdef HAVE_WS2TCPIP.H
+#include <ws2tcpip.h>
+#endif
#ifdef HAVE_NETINET_IN_H
#include <netinet/in.h>
#endif
@@ -168,6 +172,9 @@ CARES_CHECK_STRUCT(
#ifdef HAVE_WINSOCK_H
#include <winsock.h>
#endif
+#ifdef HAVE_WS2TCPIP.H
+#include <ws2tcpip.h>
+#endif
#ifdef HAVE_NETINET_IN_H
#include <netinet/in.h>
#endif
@@ -187,6 +194,9 @@ AC_CHECK_MEMBER(struct sockaddr_in6.sin6_scope_id,
#ifdef HAVE_WINSOCK_H
#include <winsock.h>
#endif
+#ifdef HAVE_WS2TCPIP.H
+#include <ws2tcpip.h>
+#endif
#ifdef HAVE_NETINET_IN_H
#include <netinet/in.h>
#endif
@@ -203,6 +213,9 @@ AC_CHECK_MEMBER(struct addrinfo.ai_flags,
#ifdef HAVE_WINSOCK_H
#include <winsock.h>
#endif
+#ifdef HAVE_WS2TCPIP.H
+#include <ws2tcpip.h>
+#endif
#ifdef HAVE_NETINET_IN_H
#include <netinet/in.h>
#endif