summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2004-02-25 14:32:39 +0000
committerDaniel Stenberg <daniel@haxx.se>2004-02-25 14:32:39 +0000
commit650fd8cee3110d3e3b3d434ce827e177b3469c36 (patch)
treeca7dc8ad27c61ac930e436cf3e2ef95007728cd1 /configure.ac
parentff2794fc5f3c26d4f87ea7cd5fca4b523d96042d (diff)
downloadc-ares-650fd8cee3110d3e3b3d434ce827e177b3469c36.tar.gz
c-ares-650fd8cee3110d3e3b3d434ce827e177b3469c36.tar.bz2
c-ares-650fd8cee3110d3e3b3d434ce827e177b3469c36.zip
added the better debug option logic from curl by adding acinclude.m4 to the
configure stuff
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 11 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 1bb474b..6d82081 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,35 +35,22 @@ AC_HELP_STRING([--disable-debug],[Disable debug options]),
CPPFLAGS="$CPPFLAGS -DCURLDEBUG -I../include"
CFLAGS="$CFLAGS -g"
- if test "$GCC" = "yes"; then
- dnl these work for gcc 2.95
- CFLAGS="$CFLAGS -W -Wall -Wwrite-strings -pedantic -Wundef -Wpointer-arith -Wnested-externs -Wcast-align -Winline -Wstrict-prototypes -Wmissing-declarations -Wmissing-prototypes -Wshadow -Wsign-compare"
- dnl 2.96 or higher: -Wfloat-equal -Wunreachable-code
- fi
- dnl strip off optimizer flags
- NEWFLAGS=""
- for flag in $CFLAGS; do
- case "$flag" in
- -O*)
- dnl echo "cut off $flag"
- ;;
- *)
- NEWFLAGS="$NEWFLAGS $flag"
- ;;
- esac
- done
- CFLAGS=$NEWFLAGS
+
+ dnl set compiler "debug" options to become more picky, and remove
+ dnl optimize options from CFLAGS
+ CURL_CC_DEBUG_OPTS
+
;;
esac ],
AC_MSG_RESULT(no)
)
dnl check for a few basic system headers we need
-AC_CHECK_HEADERS(
- sys/types.h \
- sys/time.h \
- sys/select.h \
- sys/socket.h \
- )
+dnl AC_CHECK_HEADERS(
+dnl sys/types.h \
+dnl sys/time.h \
+dnl sys/select.h \
+dnl sys/socket.h \
+dnl )
AC_OUTPUT(Makefile)