summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2005-11-14 23:14:54 +0000
committerDaniel Stenberg <daniel@haxx.se>2005-11-14 23:14:54 +0000
commit374bc69debc074fc67c187d24b52a394dc5f4656 (patch)
tree440a4803db3e8be6b5dffb54793c226f67837a87 /configure.ac
parent8e55d1b7a1fc35eb47de08591f330b68dcb3d3ab (diff)
downloadc-ares-374bc69debc074fc67c187d24b52a394dc5f4656.tar.gz
c-ares-374bc69debc074fc67c187d24b52a394dc5f4656.tar.bz2
c-ares-374bc69debc074fc67c187d24b52a394dc5f4656.zip
Detect big/little endian in the configure script and adjust the ares_dns.h
macros accordingly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f4cc523..c20685b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -356,4 +356,10 @@ CARES_CHECK_GETSERVBYPORT_R
CURL_CHECK_NONBLOCKING_SOCKET
+AC_C_BIGENDIAN(
+ [AC_DEFINE(ARES_BIG_ENDIAN, 1, [define this if ares is built for a big endian system])],
+ ,
+ [AC_MSG_WARN([couldn't figure out endianess, assuming little endian!])]
+)
+
AC_OUTPUT(Makefile)