summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2006-05-03 22:39:49 +0000
committerDaniel Stenberg <daniel@haxx.se>2006-05-03 22:39:49 +0000
commitf4f25e328258c365b75f2ff42d4bc61f9abc520d (patch)
tree4048c5a1d93b1001b758b23994ebc568e2af5606 /configure.ac
parent22e34b53e493e7f94036182ad2c6764bdc3ac5fb (diff)
downloadc-ares-f4f25e328258c365b75f2ff42d4bc61f9abc520d.tar.gz
c-ares-f4f25e328258c365b75f2ff42d4bc61f9abc520d.tar.bz2
c-ares-f4f25e328258c365b75f2ff42d4bc61f9abc520d.zip
moved the curl_off_t check to within the --enable-debug block where it belongs since it is a somewhat ugly hack
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 798ca18..ea38b89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,15 @@ AC_HELP_STRING([--disable-debug],[Disable debug options]),
CPPFLAGS="$CPPFLAGS -DCURLDEBUG -I$srcdir/../include"
CFLAGS="$CFLAGS -g"
+ dnl check for how to do large files, needed to get the curl_off_t check
+ dnl done right
+ AC_SYS_LARGEFILE
+
+ AC_CHECK_SIZEOF(curl_off_t, ,[
+#include <stdio.h>
+#include "$srcdir/../include/curl/curl.h"
+ ])
+
dnl set compiler "debug" options to become more picky, and remove
dnl optimize options from CFLAGS
CURL_CC_DEBUG_OPTS
@@ -121,10 +130,6 @@ AC_C_CONST
AC_TYPE_SIZE_T
AC_HEADER_TIME
-AC_CHECK_SIZEOF(curl_off_t, ,[
-#include <stdio.h>
-#include "$srcdir/include/curl/curl.h"
-])
AC_CHECK_SIZEOF(size_t)
AC_CHECK_SIZEOF(long)
AC_CHECK_SIZEOF(time_t)