summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-05-12 02:04:22 +0000
committerYang Tse <yangsita@gmail.com>2008-05-12 02:04:22 +0000
commite8603c5bee7cd95fad4ebddb0eda0228996d7d02 (patch)
tree778f9e43c28737177860166a1142c2ae16ff8899 /configure.ac
parent8e4de09b99b7a9aa153367724a5bc7563ed2568a (diff)
downloadc-ares-e8603c5bee7cd95fad4ebddb0eda0228996d7d02.tar.gz
c-ares-e8603c5bee7cd95fad4ebddb0eda0228996d7d02.tar.bz2
c-ares-e8603c5bee7cd95fad4ebddb0eda0228996d7d02.zip
configure script will now define HAVE_CLOCK_GETTIME_MONOTONIC symbol only
when function clock_gettime() is available and the monotonic timer is also available. Otherwise, in some cases, librt or libposix4 could be used for linking even when finally not using the clock_gettime() function due to lack of the monotonic clock.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 28f90c8..70dbcce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -261,9 +261,10 @@ dnl socket lib?
AC_CHECK_FUNC(connect, , [ AC_CHECK_LIB(socket, connect) ])
dnl **********************************************************************
-dnl Check for libraries needed for function clock_gettime
+dnl In case that function clock_gettime with monotonic timer is available,
+dnl check for additional required libraries.
dnl **********************************************************************
-CURL_CHECK_LIBS_CLOCK_GETTIME
+CURL_CHECK_LIBS_CLOCK_GETTIME_MONOTONIC
AC_MSG_CHECKING([whether to use libgcc])
AC_ARG_ENABLE(libgcc,