summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-07-15 16:43:39 +0000
committerYang Tse <yangsita@gmail.com>2008-07-15 16:43:39 +0000
commite5e2cd5659c14c832595aaf03f947382c216d109 (patch)
tree6c31520d3aedbe66df37514c00c4b401bd9adc19 /configure.ac
parent2265b9281c8172709a90ccab4255e74527a24841 (diff)
downloadc-ares-e5e2cd5659c14c832595aaf03f947382c216d109.tar.gz
c-ares-e5e2cd5659c14c832595aaf03f947382c216d109.tar.bz2
c-ares-e5e2cd5659c14c832595aaf03f947382c216d109.zip
Allow --enable-largefile and --disable-largefile configurations.
Configure process no longer needs nor checks size of curl_off_t. Library will now be built with _REENTRANT symbol defined.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 3 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 5b069cf..80eecda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,6 +75,9 @@ AC_PROG_CC
AM_PROG_CC_C_O
AC_PROG_INSTALL
+dnl check for how to do large files
+AC_SYS_LARGEFILE
+
case $host_os in
solaris*)
AC_DEFINE(ETC_INET, 1, [if a /etc/inet dir is being used])
@@ -111,15 +114,6 @@ AC_HELP_STRING([--disable-debug],[Disable debug options]),
CPPFLAGS="$CPPFLAGS -DCURLDEBUG -I$srcdir/../include"
CFLAGS="$CFLAGS -g"
- dnl check for how to do large files, needed to get the curl_off_t check
- dnl done right
- AC_SYS_LARGEFILE
-
- AC_CHECK_SIZEOF(curl_off_t, ,[
-#include <stdio.h>
-#include "$srcdir/../include/curl/curl.h"
- ])
-
dnl set compiler "debug" options to become more picky, and remove
dnl optimize options from CFLAGS
CURL_CC_DEBUG_OPTS