summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-07-19 11:27:45 +0000
committerYang Tse <yangsita@gmail.com>2008-07-19 11:27:45 +0000
commit7b0adfa38da1c94dc9e72e6e9ca5ffca1e7eb341 (patch)
treed96b1170acbe5453a8c2712769495bd8f2a48f0f /configure.ac
parent2aeb0314f57e299089e90122ca9c375c91bd56af (diff)
downloadc-ares-7b0adfa38da1c94dc9e72e6e9ca5ffca1e7eb341.tar.gz
c-ares-7b0adfa38da1c94dc9e72e6e9ca5ffca1e7eb341.tar.bz2
c-ares-7b0adfa38da1c94dc9e72e6e9ca5ffca1e7eb341.zip
Adjust DEC/Compaq C compiler settings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2f7f6c9..fbcb851 100644
--- a/configure.ac
+++ b/configure.ac
@@ -239,10 +239,12 @@ if test "$curl_cv_have_def___DECC" = "yes" ||
AC_MSG_RESULT([yes])
dnl Select strict ANSI C compiler mode
CFLAGS="$CFLAGS -std1"
- dnl Generate verbose messages for errors and warnings
- CFLAGS="$CFLAGS -verbose"
dnl Generate warnings for missing function prototypes
CFLAGS="$CFLAGS -warnprotos"
+ dnl Select highest warning level
+ CFLAGS="$CFLAGS -msg_enable level6"
+ dnl Change some warnings into fatal errors
+ CFLAGS="$CFLAGS -msg_fatal toofewargs,toomanyargs"
else
AC_MSG_RESULT([no])
fi