summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-09-08 16:48:58 +0000
committerYang Tse <yangsita@gmail.com>2008-09-08 16:48:58 +0000
commit6e781eb2c497353aeb3f4ecfbc5950b4a1d8c0eb (patch)
tree9436b53744f800d0a29de381bdae6853e3a729d3 /configure.ac
parentf33bd94c050b8ff5e8bdfc62f8d626de97543e6e (diff)
downloadc-ares-6e781eb2c497353aeb3f4ecfbc5950b4a1d8c0eb.tar.gz
c-ares-6e781eb2c497353aeb3f4ecfbc5950b4a1d8c0eb.tar.bz2
c-ares-6e781eb2c497353aeb3f4ecfbc5950b4a1d8c0eb.zip
Select strict ANSI C89 conformance for icc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6a8cf7d..fe8a7a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -229,6 +229,20 @@ else
AC_MSG_RESULT([no])
fi
+AC_MSG_CHECKING([whether we are using the Intel C compiler])
+CURL_CHECK_DEF([__INTEL_COMPILER], [], [silent])
+if test "$curl_cv_have_def___INTEL_COMPILER" = "yes"; then
+ AC_MSG_RESULT([yes])
+ dnl Select strict ANSI C conformance
+ CFLAGS="$CFLAGS -strict-ansi"
+ dnl Select ANSI C dialect
+ CFLAGS="$CFLAGS -std=c89"
+ dnl Disable use of ANSI C aliasing rules in optimizations
+ CFLAGS="$CFLAGS -no-ansi-alias"
+else
+ AC_MSG_RESULT([no])
+fi
+
AC_MSG_CHECKING([whether we are using the DEC/Compaq C compiler])
CURL_CHECK_DEF([__DECC], [], [silent])
CURL_CHECK_DEF([__DECC_VER], [], [silent])