summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-07-01 10:29:25 +0000
committerYang Tse <yangsita@gmail.com>2008-07-01 10:29:25 +0000
commit3e04944084793a478a8b95d57da13dffc93f9336 (patch)
tree99fbf2acc3decec1df5866d7408aa4cc7d70133c /configure.ac
parent83b7feb146eabcbe6b153fae215c00542a557915 (diff)
downloadc-ares-3e04944084793a478a8b95d57da13dffc93f9336.tar.gz
c-ares-3e04944084793a478a8b95d57da13dffc93f9336.tar.bz2
c-ares-3e04944084793a478a8b95d57da13dffc93f9336.zip
IBM C/C++ compiler predefined macro check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d90d70b..12b6151 100644
--- a/configure.ac
+++ b/configure.ac
@@ -162,7 +162,9 @@ esac
AC_MSG_CHECKING([whether we are using the IBM C compiler])
CURL_CHECK_DEF([__IBMC__], [], [silent])
-if test "$curl_cv_have_def___IBMC__" = "yes"; then
+CURL_CHECK_DEF([__IBMCPP__], [], [silent])
+if test "$curl_cv_have_def___IBMC__" = "yes" ||
+ test "$curl_cv_have_def___IBMCPP__" = "yes"; then
AC_MSG_RESULT([yes])
dnl Ensure that compiler optimizations are always thread-safe.
CFLAGS="$CFLAGS -qthreaded"