summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2007-12-10 22:19:06 +0000
committerDaniel Stenberg <daniel@haxx.se>2007-12-10 22:19:06 +0000
commit03431e22b23b67c55bf8404e677827fe3f014a9e (patch)
treeef010da3dae6b10625b2583fa1788621cb050cb5 /configure.ac
parent80dbaf63be1785cfc3f2edd36da84b6744af105b (diff)
downloadc-ares-03431e22b23b67c55bf8404e677827fe3f014a9e.tar.gz
c-ares-03431e22b23b67c55bf8404e677827fe3f014a9e.tar.bz2
c-ares-03431e22b23b67c55bf8404e677827fe3f014a9e.zip
when building
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f5adf73..7edc374 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,8 @@ AC_HELP_STRING([--disable-debug],[Disable debug options]),
dnl when doing the debug stuff, use static library only
AC_DISABLE_SHARED
+ debugbuild="yes"
+
dnl the entire --enable-debug is a hack that lives and runs on top of
dnl libcurl stuff so this BUILDING_LIBCURL is not THAT much uglier
AC_DEFINE(BUILDING_LIBCURL, 1, [when building as static part of libcurl])
@@ -70,6 +72,7 @@ AC_HELP_STRING([--disable-debug],[Disable debug options]),
esac ],
AC_MSG_RESULT(no)
)
+AM_CONDITIONAL(DEBUGBUILD, test x$debugbuild = xyes)
dnl skip libtool C++ and Fortran compiler checks
m4_ifdef([AC_PROG_CXX], [m4_undefine([AC_PROG_CXX])])