summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2009-11-14 18:51:37 +0000
committerYang Tse <yangsita@gmail.com>2009-11-14 18:51:37 +0000
commite43ac04a1f6a04620eaf111e144dac7f3bb2f77e (patch)
tree143b9f27e851611b1eeeffff1d3e9c298ce1fe3e /configure.ac
parentccabe949dda62bc0365fe6e624ccaecb686c1968 (diff)
downloadc-ares-e43ac04a1f6a04620eaf111e144dac7f3bb2f77e.tar.gz
c-ares-e43ac04a1f6a04620eaf111e144dac7f3bb2f77e.tar.bz2
c-ares-e43ac04a1f6a04620eaf111e144dac7f3bb2f77e.zip
Refactor how preprocessor symbol _THREAD_SAFE definition is done.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 1 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 8f1cddb..f1f52a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,6 +82,7 @@ dnl This defines _ALL_SOURCE for AIX
CARES_CHECK_AIX_ALL_SOURCE
dnl Our configure and build reentrant settings
+CARES_CONFIGURE_THREAD_SAFE
CARES_CONFIGURE_REENTRANT
dnl check for how to do large files
@@ -384,21 +385,6 @@ AC_HELP_STRING([--enable-libgcc],[use libgcc when linking]),
dnl Default is to try the thread-safe versions of a few functions
OPT_THREAD=on
-dnl detect AIX 4.3 or later
-AC_MSG_CHECKING([AIX 4.3 or later])
-AC_PREPROC_IFELSE([
-#if defined(_AIX) && defined(_AIX43)
-printf("just fine");
-#else
-#error "this is not AIX 4.3 or later"
-#endif
-],
- [ AC_MSG_RESULT([yes])
- RECENTAIX=yes
- OPT_THREAD=off ],
- [ AC_MSG_RESULT([no]) ]
-)
-
AC_ARG_ENABLE(thread,dnl
AC_HELP_STRING([--disable-thread],[don't look for thread-safe functions])
AC_HELP_STRING([--enable-thread],[look for thread-safe functions]),
@@ -427,12 +413,6 @@ dnl Let's hope this split URL remains working:
dnl http://publibn.boulder.ibm.com/doc_link/en_US/a_doc_lib/aixprggd/ \
dnl genprogc/thread_quick_ref.htm
-if test "x$RECENTAIX" = "xyes"; then
-
- AC_DEFINE(_THREAD_SAFE, 1, [define this if you need it to compile thread-safe code])
-
-fi
-
dnl **********************************************************************
dnl Back to "normal" configuring