summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2009-05-26 14:50:45 +0000
committerYang Tse <yangsita@gmail.com>2009-05-26 14:50:45 +0000
commit84aa2f8a5dee92d546165b197928b3c124d082c5 (patch)
tree7a23f260b6e0f424b6597f73a5a2cbfe63f833a9 /configure.ac
parentacd2aeb3880865ede7a338e9fd06fe41ae6ce4ee (diff)
downloadc-ares-84aa2f8a5dee92d546165b197928b3c124d082c5.tar.gz
c-ares-84aa2f8a5dee92d546165b197928b3c124d082c5.tar.bz2
c-ares-84aa2f8a5dee92d546165b197928b3c124d082c5.zip
c-ares's --enable-curldebug configure option decoupled from c-ares's --enable-debug
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index c259e4e..e8dff99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,7 @@ AM_MAINTAINER_MODE
CARES_CHECK_OPTION_DEBUG
CARES_CHECK_OPTION_OPTIMIZE
CARES_CHECK_OPTION_WARNINGS
+CARES_CHECK_OPTION_CURLDEBUG
CARES_CHECK_PATH_SEPARATOR
@@ -94,11 +95,6 @@ esac
dnl support building of Windows DLLs
AC_LIBTOOL_WIN32_DLL
-CARES_PROCESS_DEBUG_BUILD_OPTS
-
-AM_CONDITIONAL(DEBUGBUILD, test x$want_debug = xyes)
-AM_CONDITIONAL(CURLDEBUG, test x$want_debug = xyes)
-
dnl force libtool to build static libraries with PIC on AMD64-Linux & FreeBSD
AC_MSG_CHECKING([if arch-OS host is AMD64-Linux/FreeBSD (to build static libraries with PIC)])
case $host in
@@ -114,6 +110,10 @@ esac
dnl libtool setup
AC_PROG_LIBTOOL
+CARES_CHECK_CURLDEBUG
+
+AM_CONDITIONAL(CURLDEBUG, test x$want_curldebug = xyes)
+
AC_MSG_CHECKING([if we need -no-undefined])
case $host in
*-*-cygwin* | *-*-mingw* | *-*-pw32* | *-*-cegcc*)