summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-08-03 03:14:05 +0000
committerYang Tse <yangsita@gmail.com>2008-08-03 03:14:05 +0000
commitabf47388f96794523efc0b1520b7d31a9c11a5fe (patch)
treebb21535ee7aec061e14046849ec363e1a4c5e2ad /configure.ac
parent10ebec6364dfda1168630ed58815d8716f497ce8 (diff)
downloadc-ares-abf47388f96794523efc0b1520b7d31a9c11a5fe.tar.gz
c-ares-abf47388f96794523efc0b1520b7d31a9c11a5fe.tar.bz2
c-ares-abf47388f96794523efc0b1520b7d31a9c11a5fe.zip
Adjust DEC/Compaq C compiler settings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 53cbe6a..f31896c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -236,6 +236,8 @@ if test "$curl_cv_have_def___DECC" = "yes" ||
AC_MSG_RESULT([yes])
dnl Select strict ANSI C compiler mode
CFLAGS="$CFLAGS -std1"
+ dnl Turn off optimizer ANSI C aliasing rules
+ CFLAGS="$CFLAGS -noansi_alias"
dnl Select a higher warning level than default level2
CFLAGS="$CFLAGS -msg_enable level3"
dnl Generate warnings for missing function prototypes