summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-09-17 09:37:41 +0000
committerYang Tse <yangsita@gmail.com>2008-09-17 09:37:41 +0000
commit8c3c80526930605155d0e9b23db4b8eddf974941 (patch)
tree235c5f65d0d7dab349201dab44a0130b01c74be8 /configure.ac
parentfe11cb41ec63096e0f371f4bcaf052c192616c9d (diff)
downloadc-ares-8c3c80526930605155d0e9b23db4b8eddf974941.tar.gz
c-ares-8c3c80526930605155d0e9b23db4b8eddf974941.tar.bz2
c-ares-8c3c80526930605155d0e9b23db4b8eddf974941.zip
On Linux Intel's icc uses gcc's header files, so
we select ANSI C89 dialect plus GNU extensions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 159d98f..9aacaea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -226,10 +226,9 @@ AC_MSG_CHECKING([whether we are using the Intel C compiler])
CURL_CHECK_DEF([__INTEL_COMPILER], [], [silent])
if test "$curl_cv_have_def___INTEL_COMPILER" = "yes"; then
AC_MSG_RESULT([yes])
- dnl Select strict ANSI C conformance
- CPPFLAGS="$CPPFLAGS -strict-ansi"
- dnl Select ANSI C dialect
- CPPFLAGS="$CPPFLAGS -std=c89 -D__STRICT_ANSI__"
+ dnl On Linux this compiler uses gcc's header files, so
+ dnl we select ANSI C89 dialect plus GNU extensions.
+ CPPFLAGS="$CPPFLAGS -std=gnu89"
dnl Change some warnings into errors
dnl #140: too many arguments in function call
dnl #147: declaration is incompatible with 'previous one'