summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-09-09 12:19:16 +0000
committerYang Tse <yangsita@gmail.com>2008-09-09 12:19:16 +0000
commit34cc272d982bfcd39e9f2b30873bea429a5cb9f9 (patch)
treeaf09013e205f94b425a3efe0721f2cd408289f52 /configure.ac
parent6e781eb2c497353aeb3f4ecfbc5950b4a1d8c0eb (diff)
downloadc-ares-34cc272d982bfcd39e9f2b30873bea429a5cb9f9.tar.gz
c-ares-34cc272d982bfcd39e9f2b30873bea429a5cb9f9.tar.bz2
c-ares-34cc272d982bfcd39e9f2b30873bea429a5cb9f9.zip
icc adjustments
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index fe8a7a7..9c5c426 100644
--- a/configure.ac
+++ b/configure.ac
@@ -168,13 +168,6 @@ AC_MSG_RESULT($need_no_undefined)
AM_CONDITIONAL(NO_UNDEFINED, test x$need_no_undefined = xyes)
dnl **********************************************************************
-dnl check if this is the Intel ICC compiler, and if so make it stricter
-dnl (convert warning 147 into an error) so that it properly can detect the
-dnl gethostbyname_r() version
-dnl **********************************************************************
-CURL_DETECT_ICC([CFLAGS="$CFLAGS -we 147"])
-
-dnl **********************************************************************
dnl platform/compiler/architecture specific checks/flags
dnl **********************************************************************
@@ -239,6 +232,12 @@ if test "$curl_cv_have_def___INTEL_COMPILER" = "yes"; then
CFLAGS="$CFLAGS -std=c89"
dnl Disable use of ANSI C aliasing rules in optimizations
CFLAGS="$CFLAGS -no-ansi-alias"
+ dnl Change some warnings into errors
+ dnl #140: too many arguments in function call
+ dnl #147: declaration is incompatible with 'previous one'
+ dnl #165: too few arguments in function call
+ dnl #266: function declared implicitly
+ CFLAGS="$CFLAGS -we 140,147,165,266"
else
AC_MSG_RESULT([no])
fi