summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-09-30 02:59:35 +0000
committerYang Tse <yangsita@gmail.com>2008-09-30 02:59:35 +0000
commit2bc4f4c175bf113ff4d39713bd98ca6774e767cd (patch)
tree1929f8cf688a826b3af86e73c327d688a831dceb /configure.ac
parent4c1d2df804656d7b1ecb33ec0ebf64135d45f114 (diff)
downloadc-ares-2bc4f4c175bf113ff4d39713bd98ca6774e767cd.tar.gz
c-ares-2bc4f4c175bf113ff4d39713bd98ca6774e767cd.tar.bz2
c-ares-2bc4f4c175bf113ff4d39713bd98ca6774e767cd.zip
Use CFLAGS for icc linker options instead of LDFLAGS,
otherwise gethostbyname() is not detected.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3b9fad3..9a1f1a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -220,7 +220,7 @@ if test "$curl_cv_have_def___INTEL_COMPILER" = "yes"; then
dnl #279: controlling expression is constant
dnl #981: operands are evaluated in unspecified order
dnl #1469: "cc" clobber ignored
- if test "$curl_cv_def___INTEL_COMPILER" -lt "910"; then
+ if test "$ac_cv_compiler_num" -lt "910"; then
CPPFLAGS="$CPPFLAGS -wd 279"
fi
CPPFLAGS="$CPPFLAGS -wd 981,1469"
@@ -279,12 +279,12 @@ case $host in
if test "$ac_cv_compiler_num" -ge "900" &&
test "$ac_cv_compiler_num" -lt "1000"; then
dnl icc 9.X specific
- LDFLAGS="$LDFLAGS -i-dynamic"
+ CFLAGS="$CFLAGS -i-dynamic"
fi
#
if test "$ac_cv_compiler_num" -ge "1000"; then
dnl icc 10.X or later
- LDFLAGS="$LDFLAGS -shared-intel"
+ CFLAGS="$CFLAGS -shared-intel"
fi
#
fi