summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-09-19 15:59:28 +0000
committerYang Tse <yangsita@gmail.com>2008-09-19 15:59:28 +0000
commit22747a54b688ff678c6a6d68a3d3bda1f9948830 (patch)
tree4872ec8dada457ac7c97388f072f02816dd7198f /configure.ac
parent5e9d41fb2917a0fc0f81057f0ffa0c1508c1a22a (diff)
downloadc-ares-22747a54b688ff678c6a6d68a3d3bda1f9948830.tar.gz
c-ares-22747a54b688ff678c6a6d68a3d3bda1f9948830.tar.bz2
c-ares-22747a54b688ff678c6a6d68a3d3bda1f9948830.zip
icc adjustments:
Disable remark #981: operands are evaluated in unspecified order Function calls which are triggering this remark, today, do not depend on the order of evaluation of its arguments. Disable remark #1469: "cc" clobber ignored Remark triggered on htons() and ntohs() due to glibc header files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 666facd..18d2d22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -241,6 +241,10 @@ if test "$curl_cv_have_def___INTEL_COMPILER" = "yes"; then
dnl #165: too few arguments in function call
dnl #266: function declared implicitly
CPPFLAGS="$CPPFLAGS -we 140,147,165,266"
+ dnl Disable some remarks
+ dnl #981: operands are evaluated in unspecified order
+ dnl #1469: "cc" clobber ignored
+ CPPFLAGS="$CPPFLAGS -wd 981,1469"
dnl Disable use of ANSI C aliasing rules in optimizations
CFLAGS="$CFLAGS -no-ansi-alias"
else