summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2007-12-10 21:42:04 +0000
committerDaniel Stenberg <daniel@haxx.se>2007-12-10 21:42:04 +0000
commit80dbaf63be1785cfc3f2edd36da84b6744af105b (patch)
tree770207818a6592fb303b147e13761bbfd3f19559 /Makefile.am
parent6fed3ff5205ae57a20c073ab48b93860445a18c3 (diff)
downloadc-ares-80dbaf63be1785cfc3f2edd36da84b6744af105b.tar.gz
c-ares-80dbaf63be1785cfc3f2edd36da84b6744af105b.tar.bz2
c-ares-80dbaf63be1785cfc3f2edd36da84b6744af105b.zip
build ahost and adig by default but don't install them
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8454724..821ee02 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,6 +8,8 @@ MSVCFILES = vc/adig/adig.dep vc/adig/adig.dsp vc/vc.dsw vc/ahost/ahost.dep \
vc/ahost/ahost.dsp vc/areslib/areslib.dep vc/areslib/areslib.dsp \
vc/areslib/areslib.dsw
+noinst_PROGRAMS = ahost adig
+
# adig and ahost are just sample programs and thus not mentioned with the
# regular sources and headers
EXTRA_DIST = CHANGES README.cares Makefile.inc adig.c ahost.c $(man_MANS) \
@@ -63,6 +65,12 @@ libcares_ladir = $(includedir)
# what headers to install on 'make install':
libcares_la_HEADERS = ares.h ares_version.h ares_dns.h
+ahost_SOURCES = ahost.c ares_getopt.c
+ahost_LDADD = $(top_builddir)/$(lib_LTLIBRARIES)
+
+adig_SOURCES = adig.c ares_getopt.c
+adig_LDADD = $(top_builddir)/$(lib_LTLIBRARIES)
+
# Make files named *.dist replace the file without .dist extension
dist-hook:
find $(distdir) -name "*.dist" -exec rm {} \;