summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2012-04-17 12:46:22 +0200
committerYang Tse <yangsita@gmail.com>2012-04-17 13:29:59 +0200
commitfc2c91c206ef4695fd0a71371910c923b133dfd6 (patch)
treeed88c13b97b1cf8aa9585a08a8f6578a28661e3c /Makefile.am
parent41191cdd54ff7f6bbb5e65bb0cd56fe0a50b5d14 (diff)
downloadc-ares-fc2c91c206ef4695fd0a71371910c923b133dfd6.tar.gz
c-ares-fc2c91c206ef4695fd0a71371910c923b133dfd6.tar.bz2
c-ares-fc2c91c206ef4695fd0a71371910c923b133dfd6.zip
build adjustments: CARES_SYMBOL_HIDING no longer defined in config files
configure script now provides conditional definitions for Makefile.am that result in CARES_SYMBOL_HIDING being defined by resulting makefiles when appropriate.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 08d6a58..edf7b59 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,6 +103,8 @@ libcares_la_LDFLAGS = $(UNDEF) $(VER)
# Add -Werror if defined
CFLAGS += @CARES_CFLAG_EXTRAS@
+CFLAG_CARES_SYMBOL_HIDING = @CFLAG_CARES_SYMBOL_HIDING@
+
# For Windows build targets, when building or using static c-ares
if USE_CPPFLAG_CARES_STATICLIB
AM_CPPFLAGS = -DCARES_STATICLIB
@@ -110,12 +112,21 @@ else
AM_CPPFLAGS =
endif
-# For Windows build targets, when building c-ares library
+if DOING_CARES_SYMBOL_HIDING
+if USE_CPPFLAG_CARES_BUILDING_LIBRARY
+libcares_la_CPPFLAGS = $(AM_CPPFLAGS) -DCARES_SYMBOL_HIDING -DCARES_BUILDING_LIBRARY
+else
+libcares_la_CPPFLAGS = $(AM_CPPFLAGS) -DCARES_SYMBOL_HIDING
+endif
+libcares_la_CFLAGS = $(AM_CFLAGS) $(CFLAG_CARES_SYMBOL_HIDING)
+else
if USE_CPPFLAG_CARES_BUILDING_LIBRARY
libcares_la_CPPFLAGS = $(AM_CPPFLAGS) -DCARES_BUILDING_LIBRARY
else
libcares_la_CPPFLAGS = $(AM_CPPFLAGS)
endif
+libcares_la_CFLAGS = $(AM_CFLAGS)
+endif
# Makefile.inc provides the CSOURCES and HHEADERS defines
include Makefile.inc