summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2009-06-08 02:03:13 +0000
committerYang Tse <yangsita@gmail.com>2009-06-08 02:03:13 +0000
commite607ed51984917f2ff0dd395f03d6aef372c6398 (patch)
tree6d74db6b1b4095a471c05f49ee642f4b65661261 /Makefile.am
parente46626580fae0b6805803ff2afd700cbbcfcac33 (diff)
downloadc-ares-e607ed51984917f2ff0dd395f03d6aef372c6398.tar.gz
c-ares-e607ed51984917f2ff0dd395f03d6aef372c6398.tar.bz2
c-ares-e607ed51984917f2ff0dd395f03d6aef372c6398.zip
For debugging purposes...
Disable the '-export-symbols-regex' to discard this as the origin of link failures related with shared libraries and non-GNU linkers.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e80c705..7e3b966 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -91,7 +91,9 @@ if NO_UNDEFINED
UNDEF = -no-undefined
endif
+if DONT_SKIP_THE_EXPORT_SYMBOLS_REGEX
EXPORT_SYMBOLS = -export-symbols-regex '^ares_[[:alnum:]].*'
+endif
libcares_la_LDFLAGS = $(UNDEF) $(VER) $(EXPORT_SYMBOLS)