summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2004-10-24 13:02:09 +0000
committerDaniel Stenberg <daniel@haxx.se>2004-10-24 13:02:09 +0000
commit902015cfd982aaefb7819d525bc7c292f6b47e80 (patch)
treec3901c58cf3a50ee344319601f8d138707666689 /Makefile.am
parent9b9d36f8484596593ed65022d2a81da3042d4c8e (diff)
downloadc-ares-902015cfd982aaefb7819d525bc7c292f6b47e80.tar.gz
c-ares-902015cfd982aaefb7819d525bc7c292f6b47e80.tar.bz2
c-ares-902015cfd982aaefb7819d525bc7c292f6b47e80.zip
maketgz now creates a ares_version.h.dist file with the given version data
properly set, and the Makefile.am is now fixed to use that when building a new package with make dist.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d60c927..10ed5c8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,3 +55,12 @@ libcares_la_SOURCES = $(CSOURCES) $(HHEADERS)
libcares_ladir = $(includedir)
# what headers to install on 'make install':
libcares_la_HEADERS = ares.h ares_version.h
+
+# Make files named *.dist replace the file without .dist extension
+dist-hook:
+ find $(distdir) -name "*.dist" -exec rm {} \;
+ (distit=`find $(srcdir) -name "*.dist"`; \
+ for file in $$distit; do \
+ strip=`echo $$file | sed -e s/^$(srcdir)// -e s/\.dist//`; \
+ cp $$file $(distdir)$$strip; \
+ done)