summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2009-05-26 14:50:45 +0000
committerYang Tse <yangsita@gmail.com>2009-05-26 14:50:45 +0000
commit84aa2f8a5dee92d546165b197928b3c124d082c5 (patch)
tree7a23f260b6e0f424b6597f73a5a2cbfe63f833a9 /Makefile.am
parentacd2aeb3880865ede7a338e9fd06fe41ae6ce4ee (diff)
downloadc-ares-84aa2f8a5dee92d546165b197928b3c124d082c5.tar.gz
c-ares-84aa2f8a5dee92d546165b197928b3c124d082c5.tar.bz2
c-ares-84aa2f8a5dee92d546165b197928b3c124d082c5.zip
c-ares's --enable-curldebug configure option decoupled from c-ares's --enable-debug
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8dd8994..2e26a34 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,11 +14,13 @@ ACLOCAL_AMFLAGS = -I m4
# libcurl, but we do this anyway for convenience.
#
# $(top_builddir)/../include is for libcurl's generated curl/curlbuild.h file
+# $(top_srcdir)/../include is for libcurl's external include files
# $(top_builddir) is for c-ares's generated config.h file
# $(top_srcdir) is for c-ares's lib/setup.h and other "c-ares-private" files
if CURLDEBUG
INCLUDES = -I$(top_builddir)/../include \
+ -I$(top_srcdir)/../include \
-I$(top_builddir) \
-I$(top_srcdir)
else
@@ -33,7 +35,7 @@ man_MANS = $(MANPAGES)
MSVCFILES = vc/vc.dsw vc/acountry/acountry.dsp vc/adig/adig.dsp \
vc/ahost/ahost.dsp vc/areslib/areslib.dsp vc/areslib/areslib.dsw
-if DEBUGBUILD
+if CURLDEBUG
PROGS =
else
PROGS = ahost adig acountry