summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Greear <greearb@candelatech.com>2010-07-29 23:43:02 -0700
committerBen Greear <greearb@candelatech.com>2010-07-29 23:43:02 -0700
commit45557a138e60031a6e680d62aa29ddf2bf925d8c (patch)
treec21a3c4bb0d5b1e5795c208f8329e4efc1bec0e4 /Makefile.am
parent3e33e2c2ba612d19cf7c1f77c8953b012489e801 (diff)
downloadc-ares-45557a138e60031a6e680d62aa29ddf2bf925d8c.tar.gz
c-ares-45557a138e60031a6e680d62aa29ddf2bf925d8c.tar.bz2
c-ares-45557a138e60031a6e680d62aa29ddf2bf925d8c.zip
build: Enable compiling with -Werror.
This helps find compile warnings because they simply break the build. To use: ./configure --enable-warnings --enable-werror Signed-off-by: Ben Greear <greearb@candelatech.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6cb508e..672120d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -99,6 +99,9 @@ endif
libcares_la_LDFLAGS = $(UNDEF) $(VER)
+# Add -Werror if defined
+CFLAGS += @CARES_CFLAG_EXTRAS@
+
# Makefile.inc provides the CSOURCES and HHEADERS defines
include Makefile.inc