summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2007-12-10 22:19:06 +0000
committerDaniel Stenberg <daniel@haxx.se>2007-12-10 22:19:06 +0000
commit03431e22b23b67c55bf8404e677827fe3f014a9e (patch)
treeef010da3dae6b10625b2583fa1788621cb050cb5 /Makefile.am
parent80dbaf63be1785cfc3f2edd36da84b6744af105b (diff)
downloadc-ares-03431e22b23b67c55bf8404e677827fe3f014a9e.tar.gz
c-ares-03431e22b23b67c55bf8404e677827fe3f014a9e.tar.bz2
c-ares-03431e22b23b67c55bf8404e677827fe3f014a9e.zip
when building
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 821ee02..4148870 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,13 @@ MSVCFILES = vc/adig/adig.dep vc/adig/adig.dsp vc/vc.dsw vc/ahost/ahost.dep \
vc/ahost/ahost.dsp vc/areslib/areslib.dep vc/areslib/areslib.dsp \
vc/areslib/areslib.dsw
-noinst_PROGRAMS = ahost adig
+if DEBUGBUILD
+PROGS =
+else
+PROGS = ahost adig acountry
+endif
+
+noinst_PROGRAMS =$(PROGS)
# adig and ahost are just sample programs and thus not mentioned with the
# regular sources and headers
@@ -71,6 +77,9 @@ ahost_LDADD = $(top_builddir)/$(lib_LTLIBRARIES)
adig_SOURCES = adig.c ares_getopt.c
adig_LDADD = $(top_builddir)/$(lib_LTLIBRARIES)
+acountry_SOURCES = acountry.c ares_getopt.c
+acountry_LDADD = $(top_builddir)/$(lib_LTLIBRARIES)
+
# Make files named *.dist replace the file without .dist extension
dist-hook:
find $(distdir) -name "*.dist" -exec rm {} \;