summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2009-10-28 19:45:26 +0000
committerYang Tse <yangsita@gmail.com>2009-10-28 19:45:26 +0000
commit9cac6a46259f102af306840720b3af64d4b8c12a (patch)
tree831c0f65a2f425dabd2f55bfc3903e06e5f72480 /Makefile.am
parenta732ace461891719d27f4ed1e2d8a0e8399e047e (diff)
downloadc-ares-9cac6a46259f102af306840720b3af64d4b8c12a.tar.gz
c-ares-9cac6a46259f102af306840720b3af64d4b8c12a.tar.bz2
c-ares-9cac6a46259f102af306840720b3af64d4b8c12a.zip
Initial step towards the ability to reduce c-ares exported symbols
based on the 'visibility' attribute for GNUC and __global for Sun compilers, taking also in account __declspec function decoration for Win32 and Symbian DLL's. Introducing configure options --enable-hidden-symbols and --disable-hidden-symbols following libcurl's naming.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 302ac9d..b1f364a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -91,9 +91,7 @@ if NO_UNDEFINED
UNDEF = -no-undefined
endif
-# EXPORT_SYMBOLS = -export-symbols-regex '^ares_[[:alnum:]].*'
-
-libcares_la_LDFLAGS = $(UNDEF) $(VER) $(EXPORT_SYMBOLS)
+libcares_la_LDFLAGS = $(UNDEF) $(VER)
# Makefile.inc provides the CSOURCES and HHEADERS defines
include Makefile.inc