summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2009-11-05 17:44:29 +0000
committerYang Tse <yangsita@gmail.com>2009-11-05 17:44:29 +0000
commit54fafaa0880311f5150aa6b6d954e8734e1aeb62 (patch)
treef777b6e4347a9c0a1c20d8d6d565d8aa8c988e69 /Makefile.am
parente057b523af459e091610c605c4fb9c4ede75fd3c (diff)
downloadc-ares-54fafaa0880311f5150aa6b6d954e8734e1aeb62.tar.gz
c-ares-54fafaa0880311f5150aa6b6d954e8734e1aeb62.tar.bz2
c-ares-54fafaa0880311f5150aa6b6d954e8734e1aeb62.zip
Adjust c-ares include paths for memory tracking enabled (--enable-curldebug) builds
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 01b7f08..df0f878 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,6 +13,7 @@ ACLOCAL_AMFLAGS = -I m4
# only works when c-ares is built and linked with a similarly debug-build
# libcurl, but we do this anyway for convenience.
#
+# $(top_builddir)/../include/curl for generated curlbuild.h included from curl.h
# $(top_builddir)/../include is for libcurl's generated curl/curlbuild.h file
# $(top_srcdir)/../include is for libcurl's external include files
# $(top_builddir)/../lib is for libcurl's generated lib/curl_config.h file
@@ -21,11 +22,12 @@ ACLOCAL_AMFLAGS = -I m4
# $(top_srcdir) is for c-ares's ares_setup.h and other "c-ares-private" files
if CURLDEBUG
-INCLUDES = -I$(top_builddir)/../include \
- -I$(top_srcdir)/../include \
- -I$(top_builddir)/../lib \
- -I$(top_srcdir)/../lib \
- -I$(top_builddir) \
+INCLUDES = -I$(top_builddir)/../include/curl \
+ -I$(top_builddir)/../include \
+ -I$(top_srcdir)/../include \
+ -I$(top_builddir)/../lib \
+ -I$(top_srcdir)/../lib \
+ -I$(top_builddir) \
-I$(top_srcdir)
else
INCLUDES = -I$(top_builddir) \