summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-10-30 13:14:52 -0700
committerAnas Nashif <anas.nashif@intel.com>2012-10-30 13:14:52 -0700
commite4ea3febc82023700035016f0f66426682b87a8a (patch)
treef0861f825ef37ef8e90541e6543397539bc7319f /configure.ac
downloadbootchart-e4ea3febc82023700035016f0f66426682b87a8a.tar.gz
bootchart-e4ea3febc82023700035016f0f66426682b87a8a.tar.bz2
bootchart-e4ea3febc82023700035016f0f66426682b87a8a.zip
Imported Upstream version 1.20upstream/1.20upstream
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..8f09bc3
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,30 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.68])
+AC_INIT([bootchart], [1.20], [auke-jan.h.kok@intel.com])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_CONFIG_SRCDIR([bootchart.c])
+AC_CONFIG_HEADERS([config.h])
+
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_CC
+AC_PROG_INSTALL
+
+# Checks for libraries.
+AC_CHECK_LIB([rt], [clock_gettime])
+
+# Checks for header files.
+AC_CHECK_HEADERS([fcntl.h limits.h stdlib.h string.h sys/time.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+
+# Checks for library functions.
+AC_FUNC_FORK
+AC_FUNC_MALLOC
+AC_FUNC_STRTOD
+AC_CHECK_FUNCS([clock_gettime memset strchr strstr uname])
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT