summaryrefslogtreecommitdiff
path: root/packaging/boost.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/boost.spec')
-rw-r--r--packaging/boost.spec37
1 files changed, 26 insertions, 11 deletions
diff --git a/packaging/boost.spec b/packaging/boost.spec
index 13fd083bf1..86b858f84d 100644
--- a/packaging/boost.spec
+++ b/packaging/boost.spec
@@ -4,9 +4,9 @@
%define check %%check
%endif
-%define ver 1.58.0
-%define file_version 1_58_0
-%define short_version 1_58
+%define ver 1.62.0
+%define file_version 1_62_0
+%define short_version 1_62
#Only define to 1 to generate the man pages
%define build_docs 0
@@ -69,7 +69,7 @@ Url: http://www.boost.org
Summary: Boost C++ Libraries
License: BSL-1.0
Group: Base/Libraries
-Version: 1.58.0
+Version: 1.62.0
Release: 0
Source0: %{name}_%{file_version}.tar.bz2
Source1: boost-rpmlintrc
@@ -356,6 +356,14 @@ Provides: boost-timer
%description -n boost-timer
This package contains the Boost::Timer runtime library.
+%package -n boost_type_erasure
+Summary: The Boost::TypeErasure runtime library
+Group: System/Libraries
+Requires: boost-license
+
+%description -n boost_type_erasure
+This package contains the Boost::TypeErasure runtime library.
+
%prep
%setup -q -n %{name}_%{file_version}
@@ -504,13 +512,14 @@ install -D -m 644 %{SOURCE1002} $RPM_BUILD_ROOT%{_libdir}/pkgconfig
# popd
#install doc files
-dos2unix libs/ptr_container/doc/tutorial_example.html \
- libs/parameter/doc/html/reference.html \
- libs/parameter/doc/html/index.html \
- libs/iostreams/doc/tree/tree.js \
- libs/graph/doc/lengauer_tarjan_dominator.htm \
- libs/test/test/test_files/errors_handling_test.pattern \
- libs/test/test/test_files/result_report_test.pattern
+#dos2unix libs/ptr_container/doc/tutorial_example.html \
+# libs/parameter/doc/html/reference.html \
+# libs/parameter/doc/html/index.html \
+# libs/iostreams/doc/tree/tree.js \
+# libs/graph/doc/lengauer_tarjan_dominator.htm \
+# libs/test/test/test_files/errors_handling_test.pattern \
+# libs/test/test/test_files/result_report_test.pattern
+
find . -name \*.htm\* -o -name \*.gif -o -name \*.css -o -name \*.jpg -o -name \*.png -o -name \*.ico | \
tar --files-from=%{S:4} -cf - --files-from=- | tar -C %{buildroot}%{_docdir} -xf -
rm -rf %{buildroot}%{_docdir}/boost
@@ -549,6 +558,7 @@ cp -af LICENSE_1_0.txt %{buildroot}/usr/share/licenses/%{name}
%post -n boost-signals -p /sbin/ldconfig
%post -n boost-thread -p /sbin/ldconfig
%post -n boost-math -p /sbin/ldconfig
+%post -n boost_type_erasure -p /sbin/ldconfig
%if %build_mpi
%post -n boost-mpi -p /sbin/ldconfig
%endif
@@ -579,6 +589,7 @@ cp -af LICENSE_1_0.txt %{buildroot}/usr/share/licenses/%{name}
%postun -n boost-signals -p /sbin/ldconfig
%postun -n boost-thread -p /sbin/ldconfig
%postun -n boost-math -p /sbin/ldconfig
+%postun -n boost_type_erasure -p /sbin/ldconfig
%if %build_mpi
%postun -n boost-mpi -p /sbin/ldconfig
%endif
@@ -663,6 +674,10 @@ cp -af LICENSE_1_0.txt %{buildroot}/usr/share/licenses/%{name}
%defattr(-, root, root, -)
%{_libdir}/libboost_math_*.so.*
+%files -n boost_type_erasure
+%defattr(-, root, root, -)
+%{_libdir}/libboost_type_erasure*.so.*
+
%if %build_mpi
%manifest %{name}.manifest
%files -n boost-mpi