summaryrefslogtreecommitdiff
path: root/packaging/boost.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/boost.spec')
-rw-r--r--packaging/boost.spec34
1 files changed, 26 insertions, 8 deletions
diff --git a/packaging/boost.spec b/packaging/boost.spec
index 6a57ac2b88..a35f906bb8 100644
--- a/packaging/boost.spec
+++ b/packaging/boost.spec
@@ -1,12 +1,11 @@
-%define run_tests 0
-%if %{run_tests}
+%if "%{run_tests}" == "1"
# check is defined off at .rpmmacros file.
%define check %%check
%endif
-%define ver 1.62.0
-%define file_version 1_62_0
-%define short_version 1_62
+%define ver 1.65.1
+%define file_version 1_65_0
+%define short_version 1_65
#Only define to 1 to generate the man pages
%define build_docs 0
@@ -26,7 +25,7 @@
%define boost_libs4 boost-signals boost-system boost-thread
%define boost_libs5 boost-wave boost-regex
%define boost_libs6 boost-random boost-chrono boost-locale
-%define boost_libs7 boost-timer boost-atomic boost-log boost-container
+%define boost_libs7 boost-timer boost-atomic boost-log boost-container boost_stacktrace
%define most_libs %boost_libs1 %boost_libs2 %boost_libs3 %boost_libs4 %boost_libs5 %boost_libs6 %boost_libs7
@@ -71,7 +70,7 @@ Url: http://www.boost.org
Summary: Boost C++ Libraries
License: BSL-1.0
Group: Base/Libraries
-Version: 1.62.0
+Version: 1.65.1
Release: 0
Source0: %{name}_%{file_version}.tar.bz2
Source1: boost-rpmlintrc
@@ -299,6 +298,15 @@ Provides: boost-signals
%description -n boost-signals
This package contains the Boost::Signals Runtime libraries.
+
+%package -n boost_stacktrace
+Summary: Boost.Stacktrace runtime library
+Group: System/Libraries
+Requires: boost-license
+
+%description -n boost_stacktrace
+This package contains the Boost.Stacktrace runtime library.
+
%package -n boost-system
Summary: Boost::System Runtime Libraries
Group: System/Libraries
@@ -477,7 +485,7 @@ cd doc
%endif
%check
-%if %{run_tests}
+%if "%{run_tests}" == "1"
BOOST_LIBS="chrono,program_options,thread,system,filesystem,date_time,regex,serialization,iostreams,random,test"
chmod 777 ./run_test.sh
echo "RUN run_test.sh"
@@ -588,6 +596,7 @@ rm -f %{buildroot}%{_libdir}/*.a
%post -n boost-mpi -p /sbin/ldconfig
%endif
%post -n boost-graph -p /sbin/ldconfig
+%post -n boost_stacktrace -p /sbin/ldconfig
%post -n boost-system -p /sbin/ldconfig
%post -n boost-wave -p /sbin/ldconfig
%post -n boost-random -p /sbin/ldconfig
@@ -627,6 +636,7 @@ rm -f %{buildroot}%{_libdir}/*.a
%postun -n boost-mpi -p /sbin/ldconfig
%endif
%postun -n boost-graph -p /sbin/ldconfig
+%postun -n boost_stacktrace -p /sbin/ldconfig
%postun -n boost-system -p /sbin/ldconfig
%postun -n boost-wave -p /sbin/ldconfig
%postun -n boost-random -p /sbin/ldconfig
@@ -770,6 +780,14 @@ rm -f %{buildroot}%{_libdir}/*.a
%license LICENSE_1_0.txt
%{_libdir}/libboost_signals*.so.*
+%files -n boost_stacktrace
+%manifest %{name}.manifest
+%defattr(-, root, root, -)
+%license LICENSE_1_0.txt
+%{_libdir}/libboost_stacktrace_addr2line.so.*
+%{_libdir}/libboost_stacktrace_basic.so.*
+%{_libdir}/libboost_stacktrace_noop.so.*
+
%files -n boost-system
%manifest %{name}.manifest
%defattr(-, root, root, -)