summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2014-01-05 18:02:56 +0200
committerMikko Ylinen <mikko.ylinen@intel.com>2014-09-23 21:29:41 +0300
commit5b444f8930a2635d52a676f0600e80828cc876c9 (patch)
tree4ab7bc5fb3faea5424ca03718f2d0fe03e8fe02b /configure.ac
parent253e449f63487c7738237e51137b5523104c2da3 (diff)
downloadbluez-5b444f8930a2635d52a676f0600e80828cc876c9.tar.gz
bluez-5b444f8930a2635d52a676f0600e80828cc876c9.tar.bz2
bluez-5b444f8930a2635d52a676f0600e80828cc876c9.zip
plugins: Add initial code for service plugin
This plugin will be used to control services individually.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d858ff68..6d31dd3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -221,6 +221,10 @@ AC_ARG_ENABLE(sixaxis, AC_HELP_STRING([--enable-sixaxis],
AM_CONDITIONAL(SIXAXIS, test "${enable_sixaxis}" = "yes" &&
test "${enable_udev}" != "no")
+AC_ARG_ENABLE(service, AC_HELP_STRING([--enable-service],
+ [enable service plugin]), [enable_service=${enableval}])
+AM_CONDITIONAL(SERVICE, test "${enable_service}" = "yes")
+
if (test "${prefix}" = "NONE"); then
dnl no prefix and no localstatedir, so default to /var
if (test "$localstatedir" = '${prefix}/var'); then