summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJuan Ramos <juan@lunarg.com>2023-01-27 14:32:07 -0700
committerJuan Ramos <114601453+juan-lunarg@users.noreply.github.com>2023-01-27 14:44:31 -0700
commitb271b459c7e79eddd52dd7af01ee4d012c48b1e5 (patch)
tree67a03929fb050438240ac095a8835ee33109c564 /CMakeLists.txt
parent8ad79c18ffb12cf903cad96a196c33d335f0cdb4 (diff)
downloadVulkan-Tools-b271b459c7e79eddd52dd7af01ee4d012c48b1e5.tar.gz
Vulkan-Tools-b271b459c7e79eddd52dd7af01ee4d012c48b1e5.tar.bz2
Vulkan-Tools-b271b459c7e79eddd52dd7af01ee4d012c48b1e5.zip
cmake: Raise min to 3.17
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ea2b49f..9821a426 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
# ~~~
-# Copyright (c) 2014-2022 Valve Corporation
-# Copyright (c) 2014-2022 LunarG, Inc.
+# Copyright (c) 2014-2023 Valve Corporation
+# Copyright (c) 2014-2023 LunarG, Inc.
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -14,7 +14,7 @@
# See the License for the specific language governing permissions and
# limitations under the License.
# ~~~
-cmake_minimum_required(VERSION 3.10.2)
+cmake_minimum_required(VERSION 3.17.2)
project(Vulkan-Tools)
@@ -145,6 +145,7 @@ elseif(MSVC)
if(BUILD_WERROR)
add_compile_options("/WX")
endif()
+ add_compile_options("/W3")
# Warn about nested declarations
add_compile_options("/w34456")
# Warn about potentially uninitialized variables