summaryrefslogtreecommitdiff
path: root/packaging/rinato-linux-kernel.spec
diff options
context:
space:
mode:
authorChanho Park <chanho61.park@samsung.com>2014-10-08 11:20:19 +0900
committerChanho Park <chanho61.park@samsung.com>2014-11-18 12:00:58 +0900
commit7c000e672ffdbf4aaa7e89bca89e253148e1cb68 (patch)
treed11496b31e7b0436acf89e0fe70dd99fcffcb9d8 /packaging/rinato-linux-kernel.spec
parentce9244e44d87ba50df93db1966bbb1fadfeea090 (diff)
downloadlinux-3.10-7c000e672ffdbf4aaa7e89bca89e253148e1cb68.tar.gz
linux-3.10-7c000e672ffdbf4aaa7e89bca89e253148e1cb68.tar.bz2
linux-3.10-7c000e672ffdbf4aaa7e89bca89e253148e1cb68.zip
packaging: support multiple boards
We support three boards, trats2(RD-PQ)/odroid-u3 and rinato(Galaxy Gear2). To avoid overwrite headers package, only provide the package in Mobile profile. Change-Id: I03b423da193bb2f654a40e959b01458401b49437 Signed-off-by: Chanho Park <chanho61.park@samsung.com>
Diffstat (limited to 'packaging/rinato-linux-kernel.spec')
-rw-r--r--packaging/rinato-linux-kernel.spec70
1 files changed, 70 insertions, 0 deletions
diff --git a/packaging/rinato-linux-kernel.spec b/packaging/rinato-linux-kernel.spec
new file mode 100644
index 00000000000..925f5b9e182
--- /dev/null
+++ b/packaging/rinato-linux-kernel.spec
@@ -0,0 +1,70 @@
+%define config_name tizen_rinato_defconfig
+%define buildarch arm
+%define target_board rinato
+%define variant %{buildarch}-%{target_board}
+
+Name: rinato-linux-kernel
+Summary: The Linux Kernel for Samsung Gear2
+Version: 3.10.52
+Release: 0
+License: GPL-2.0
+ExclusiveArch: %{arm}
+Group: System/Kernel
+Vendor: The Linux Community
+URL: http://www.kernel.org
+Source0: %{name}-%{version}.tar.xz
+BuildRoot: %{_tmppath}/%{name}-%{PACKAGE_VERSION}-root
+
+%define fullVersion %{version}-%{variant}
+
+BuildRequires: bc
+BuildRequires: e2fsprogs >= 1.42.11
+
+%description
+The Linux Kernel, the operating system core itself
+
+%package -n %{variant}-linux-kernel
+Summary: Tizen kernel for %{target_board}
+Group: System/Kernel
+Provides: %{variant}-odroid-kernel-profile-%{profile} = %{version}-%{release}
+Provides: %{variant}-kernel-uname-r = %{fullVersion}
+
+%description -n %{variant}-linux-kernel
+This package contains the Linux kernel for Tizen (%{profile} profile, arch %{buildarch}, target board %{target_board})
+
+%prep
+%setup -q
+
+%build
+# Make sure EXTRAVERSION says what we want it to say
+sed -i "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}-%{variant}/" Makefile
+
+# 1. Compile sources
+make %{config_name}
+make %{?_smp_mflags}
+
+# 2. Build zImage
+make zImage %{?_smp_mflags}
+make dtbs %{?_smp_mflags}
+
+# 3. Build modules
+make modules %{?_smp_mflags}
+
+%install
+QA_SKIP_BUILD_ROOT="DO_NOT_WANT"; export QA_SKIP_BUILD_ROOT
+
+# 1. Destynation directories
+mkdir -p %{buildroot}/var/tmp/boot/
+
+# 2. Install zImage
+cat arch/arm/boot/zImage arch/arm/boot/dts/exynos3250-rinato.dtb > %{buildroot}/var/tmp/boot/zImage
+
+rm -rf %{buildroot}/System.map*
+rm -rf %{buildroot}/vmlinux*
+
+%clean
+rm -rf %{buildroot}
+
+%files -n %{variant}-linux-kernel
+%license COPYING
+/var/tmp/boot/zImage