summaryrefslogtreecommitdiff
path: root/packaging/hal-rootstrap.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/hal-rootstrap.spec')
-rw-r--r--packaging/hal-rootstrap.spec10
1 files changed, 8 insertions, 2 deletions
diff --git a/packaging/hal-rootstrap.spec b/packaging/hal-rootstrap.spec
index 4becef8..9362f38 100644
--- a/packaging/hal-rootstrap.spec
+++ b/packaging/hal-rootstrap.spec
@@ -6,6 +6,12 @@
%define headed_devel_name hal-rootstrap-headed-devel
%define hal_rootstrap_headed_install_path /opt/data/hal-rootstrap/headed
+%if "%{mv_prj}" == "1"
+%define build_profile "tv"
+%else
+%define build_profile %{tizen_profile_name}
+%endif
+
Name: hal-rootstrap
Summary: Package for rootstrap of hal
Version: 0.1.0
@@ -64,13 +70,13 @@ mkdir %{buildroot}
mkdir -p %{buildroot}%{_libdir}/pkgconfig/
# hal-rootstrap
-./generate_rootstrap.sh "%{_arch}" "common" "%{buildroot}%{hal_rootstrap_install_path}"
+./generate_rootstrap.sh "%{_arch}" "common" "%{buildroot}%{hal_rootstrap_install_path}" "%{build_profile}"
cp packaging/hal-rootstrap.pc %{buildroot}%{_libdir}/pkgconfig/
./modify_pc.py "%{buildroot}%{_libdir}/pkgconfig/hal-rootstrap.pc" "%{buildroot}%{hal_rootstrap_install_path}/%{_libdir}/pkgconfig"
rm -f "%{buildroot}%{hal_rootstrap_install_path}/%{_libdir}/pkgconfig/*.pc"
# hal-rootstrap-headed
-./generate_rootstrap.sh "%{_arch}" "headed" "%{buildroot}%{hal_rootstrap_headed_install_path}"
+./generate_rootstrap.sh "%{_arch}" "headed" "%{buildroot}%{hal_rootstrap_headed_install_path}" "%{build_profile}"
cp packaging/hal-rootstrap-headed.pc %{buildroot}%{_libdir}/pkgconfig/
./modify_pc.py "%{buildroot}%{_libdir}/pkgconfig/hal-rootstrap-headed.pc" "%{buildroot}%{hal_rootstrap_headed_install_path}/%{_libdir}/pkgconfig"
rm -f "%{buildroot}%{hal_rootstrap_headed_install_path}/%{_libdir}/pkgconfig/*.pc"